Thursday, 4 October 2012

VS2012/.NET4.5 and Server 2003

Just a word of warning:

Windows NT and Windows Server 2003 do not support .NET 4.5 - you can not install the framework onto these systems.

So if you are building in visual studio 2012 and have to support Server 2003 (or earlier) then you must remember to target .NET4.0 (or lower) in your project(s) otherwise you will not be able to run them on the target system. That would be a really bad thing to find at the end of the project; another good reason to implement continuous integration/deployment into any project from the outset (and deploy to an instance/server that represents the target o/s)

No comments:

Post a Comment